Ubuntu-RS forumi
Instalacija programa iz .tar.bz2 fajla - Verzija za Štampu

+- Ubuntu-RS forumi (http://forum.ubuntu-rs.org)
+-- Forum: Ubuntu Srbija caffe (/Forum-ubuntu-srbija-caffe)
+--- Forum: Chat (/Forum-chat)
+--- Tema: Instalacija programa iz .tar.bz2 fajla (/Thread-instalacija-programa-iz-tar-bz2-fajla)



Instalacija programa iz .tar.bz2 fajla - Kolega2357 - 08.11.2018. 13.17

Kako instaliram program na Ubuntu iz .tar.bz2 fajla?


RE: Instalacija programa iz .tar.bz2 fajla - djetvan - 09.11.2018. 08.54

(08.11.2018. 13.17 )Kolega2357 Piše:  Kako instaliram program na Ubuntu iz .tar.bz2 fajla?

Evo ti pa proučavaj : https://www.google.com/search?client=ubuntu&channel=fs&q=how+to+install+tar.bz2+file+in+centos&ie=utf-8&oe=utf-8


RE: Instalacija programa iz .tar.bz2 fajla - hightech - 09.11.2018. 10.54

Prvo raspakuj
Kod:
tar jvxf program.tar.bz2
Pa udji u direktorijum
Kod:
cd program/
Pa
Kod:
./configure
Zatim
Kod:
make
Pa
Kod:
sudo make install

To bi trebalo da bude tako. Ali sve zavisi od slucaja do slucaja.


RE: Instalacija programa iz .tar.bz2 fajla - Kolega2357 - 10.11.2018. 09.14

Kod:
Kolega2357@HP500BMicrotower:~/Downloads/st-v098d_linux-x86_64$ ./configure
bash: ./configure: No such file or directory

Dobio sam ovu poruku kada sam stigao do ./configure


RE: Instalacija programa iz .tar.bz2 fajla - calexx - 10.11.2018. 12.20

Мени се често деси да нека зависност недостаје па пратим упутство да то решим, онда фали нешто друго и углавном и одустанем. У архиви би требало да постоји readme фајл са упутством али није 100% сигурно да ће да помогне кад онако крене.
Зато сам давно решио да нешто инсталирам само ако га има међу понуђеним софтвером или постоји варијанта са PPA или .deb фајлом. Зато ми је и бољи Арчи који сам препакује и инсталира.


RE: Instalacija programa iz .tar.bz2 fajla - promis - 10.11.2018. 13.59

Sve zavisi šta je u tom .tar.bz2 fajlu. Može biti:
  1. Izvorni kȏd
  2. install shell skript
  3. klot binarni fajl
  4. folder sa binarim fajlovima
U zavisnosti od toga zavisi dalji postupak.


RE: Instalacija programa iz .tar.bz2 fajla - Kolega2357 - 10.11.2018. 15.14

https://prnt.sc/lgo09k Ovo je sve od fajlova sto ima u folderu za instalaciju.


RE: Instalacija programa iz .tar.bz2 fajla - hightech - 10.11.2018. 16.44

Probaj ovo
Kod:
./skulltag
Mada evo ti ovde manual
http://www.skulltag.com/stmanual/


RE: Instalacija programa iz .tar.bz2 fajla - zika - 10.11.2018. 17.04

Baš pijaca... Wink


RE: Instalacija programa iz .tar.bz2 fajla - djetvan - 10.11.2018. 17.43

(10.11.2018. 15.14 )Kolega2357 Piše:  https://prnt.sc/lgo09k Ovo je sve od fajlova sto ima u folderu za instalaciju.

Meni često uspeva instalacija iz takvih fajlova pa sam pomislio da zatražim dotični fajl i da pokušam da pomognem ali kada sam saznao da je u pitanju igrica, sorry, za to nemam afiniteta.


RE: Instalacija programa iz .tar.bz2 fajla - promis - 10.11.2018. 17.49

Koliko vidim u pitanju je opcija br. 4.
Samo se pokrene fajl kao što je već naveo hightech.
Eventualno pre toga mu dodati izvršna ovlašćenja ako je potrebno.


RE: Instalacija programa iz .tar.bz2 fajla - Kolega2357 - 10.11.2018. 23.28

Kod:
Kolega2357@HP500BMicrotower:~/Downloads/st-v098d_linux-x86_64$ ./skulltag
./skulltag: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory



RE: Instalacija programa iz .tar.bz2 fajla - promis - 11.11.2018. 00.41

Ja, tako to ide kada se koriste binarni fajlovi...
Uradi ovo
Kod:
ldd ./skulltag
pa vidi šta ti sve fali, pa onda instaliraj biblioteke iz riznice.


RE: Instalacija programa iz .tar.bz2 fajla - calexx - 11.11.2018. 13.12

А ово?
Citat:Ubuntu Packages

If you use Ubuntu Linux or another Debian based Linux you may attempt to install Skulltag through our apt repository. Packages are provided for stable releases Doomseeker as well as Skulltag. Although any Debian based Linux should accept these packages they are only tested to work under the latest releases of Ubuntu. Both x86 and x86_64/AMD64 architectures are supported.

To use add `deb http://skulltag.net/download/files/release/deb stable multiverse` to your third party package sources. Then install the skulltag and doomseeker-skulltag packages.

Или ово?
https://ubuntuforums.org/showthread.php?t=1410889


RE: Instalacija programa iz .tar.bz2 fajla - Kolega2357 - 11.11.2018. 23.15

Kod:
Kolega2357@HP500BMicrotower:~/Downloads/st-v098d_linux-x86_64$ ldd ./skulltag
    linux-vdso.so.1 (0x00007ffd713fc000)
    libgtk-x11-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0 (0x00007fd35f6ff000)
    libgdk-x11-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgdk-x11-2.0.so.0 (0x00007fd35f44a000)
    libatk-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libatk-1.0.so.0 (0x00007fd35f224000)
    libgio-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0 (0x00007fd35ee85000)
    libpangoft2-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libpangoft2-1.0.so.0 (0x00007fd35ec6f000)
    libpangocairo-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libpangocairo-1.0.so.0 (0x00007fd35ea62000)
    libgdk_pixbuf-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgdk_pixbuf-2.0.so.0 (0x00007fd35e83e000)
    libcairo.so.2 => /usr/lib/x86_64-linux-gnu/libcairo.so.2 (0x00007fd35e521000)
    libpng12.so.0 => not found
    libpango-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libpango-1.0.so.0 (0x00007fd35e2d4000)
    libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007fd35e020000)
    libfontconfig.so.1 => /usr/lib/x86_64-linux-gnu/libfontconfig.so.1 (0x00007fd35dddb000)
    libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007fd35db87000)
    libgmodule-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0 (0x00007fd35d983000)
    libgthread-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgthread-2.0.so.0 (0x00007fd35d781000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007fd35d579000)
    libglib-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007fd35d263000)
    libSDL-1.2.so.0 => /usr/lib/x86_64-linux-gnu/libSDL-1.2.so.0 (0x00007fd35cfcb000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fd35cdac000)
    libGLU.so.1 => /usr/lib/x86_64-linux-gnu/libGLU.so.1 (0x00007fd35cb3d000)
    libGL.so.1 => /usr/lib/x86_64-linux-gnu/libGL.so.1 (0x00007fd35c8b1000)
    libSM.so.6 => /usr/lib/x86_64-linux-gnu/libSM.so.6 (0x00007fd35c6a9000)
    libICE.so.6 => /usr/lib/x86_64-linux-gnu/libICE.so.6 (0x00007fd35c48e000)
    libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007fd35c156000)
    libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007fd35bf44000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007fd35bd27000)
    libjpeg.so.62 => not found
    libfmodex64-4.24.16.so => not found
    libsnes_spc.so => not found
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fd35b99e000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fd35b600000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fd35b3e8000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fd35aff7000)
    libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007fd35adf1000)
    libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007fd35abe7000)
    libXinerama.so.1 => /usr/lib/x86_64-linux-gnu/libXinerama.so.1 (0x00007fd35a9e4000)
    libXi.so.6 => /usr/lib/x86_64-linux-gnu/libXi.so.6 (0x00007fd35a7d4000)
    libXrandr.so.2 => /usr/lib/x86_64-linux-gnu/libXrandr.so.2 (0x00007fd35a5c9000)
    libXcursor.so.1 => /usr/lib/x86_64-linux-gnu/libXcursor.so.1 (0x00007fd35a3bf000)
    libXcomposite.so.1 => /usr/lib/x86_64-linux-gnu/libXcomposite.so.1 (0x00007fd35a1bc000)
    libXdamage.so.1 => /usr/lib/x86_64-linux-gnu/libXdamage.so.1 (0x00007fd359fb9000)
    libselinux.so.1 => /lib/x86_64-linux-gnu/libselinux.so.1 (0x00007fd359d91000)
    libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007fd359b76000)
    libmount.so.1 => /lib/x86_64-linux-gnu/libmount.so.1 (0x00007fd359922000)
    libharfbuzz.so.0 => /usr/lib/x86_64-linux-gnu/libharfbuzz.so.0 (0x00007fd359684000)
    libpixman-1.so.0 => /usr/lib/x86_64-linux-gnu/libpixman-1.so.0 (0x00007fd3593df000)
    libpng16.so.16 => /usr/lib/x86_64-linux-gnu/libpng16.so.16 (0x00007fd3591ad000)
    libxcb-shm.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-shm.so.0 (0x00007fd358faa000)
    libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007fd358d82000)
    libxcb-render.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-render.so.0 (0x00007fd358b75000)
    libthai.so.0 => /usr/lib/x86_64-linux-gnu/libthai.so.0 (0x00007fd35896c000)
    libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007fd35873a000)
    libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007fd358532000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fd35832e000)
    libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007fd3580bc000)
    libasound.so.2 => /usr/lib/x86_64-linux-gnu/libasound.so.2 (0x00007fd357db6000)
    libpulse-simple.so.0 => /usr/lib/x86_64-linux-gnu/libpulse-simple.so.0 (0x00007fd357bb1000)
    libpulse.so.0 => /usr/lib/x86_64-linux-gnu/libpulse.so.0 (0x00007fd357961000)
    libcaca.so.0 => /usr/lib/x86_64-linux-gnu/libcaca.so.0 (0x00007fd357698000)
    /lib64/ld-linux-x86-64.so.2 (0x00007fd35fd41000)
    libGLX.so.0 => /usr/lib/x86_64-linux-gnu/libGLX.so.0 (0x00007fd357467000)
    libGLdispatch.so.0 => /usr/lib/x86_64-linux-gnu/libGLdispatch.so.0 (0x00007fd3571b1000)
    libuuid.so.1 => /lib/x86_64-linux-gnu/libuuid.so.1 (0x00007fd356faa000)
    libbsd.so.0 => /lib/x86_64-linux-gnu/libbsd.so.0 (0x00007fd356d95000)
    libblkid.so.1 => /lib/x86_64-linux-gnu/libblkid.so.1 (0x00007fd356b48000)
    libgraphite2.so.3 => /usr/lib/x86_64-linux-gnu/libgraphite2.so.3 (0x00007fd35691b000)
    libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007fd356717000)
    libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007fd356511000)
    libdatrie.so.1 => /usr/lib/x86_64-linux-gnu/libdatrie.so.1 (0x00007fd35630a000)
    libpulsecommon-11.1.so => /usr/lib/x86_64-linux-gnu/pulseaudio/libpulsecommon-11.1.so (0x00007fd35608c000)
    libdbus-1.so.3 => /lib/x86_64-linux-gnu/libdbus-1.so.3 (0x00007fd355e3f000)
    libslang.so.2 => /lib/x86_64-linux-gnu/libslang.so.2 (0x00007fd35595d000)
    libncursesw.so.5 => /lib/x86_64-linux-gnu/libncursesw.so.5 (0x00007fd35572e000)
    libtinfo.so.5 => /lib/x86_64-linux-gnu/libtinfo.so.5 (0x00007fd355504000)
    libsystemd.so.0 => /lib/x86_64-linux-gnu/libsystemd.so.0 (0x00007fd355280000)
    libwrap.so.0 => /lib/x86_64-linux-gnu/libwrap.so.0 (0x00007fd355076000)
    libsndfile.so.1 => /usr/lib/x86_64-linux-gnu/libsndfile.so.1 (0x00007fd354dfd000)
    libasyncns.so.0 => /usr/lib/x86_64-linux-gnu/libasyncns.so.0 (0x00007fd354bf7000)
    liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007fd3549d1000)
    liblz4.so.1 => /usr/lib/x86_64-linux-gnu/liblz4.so.1 (0x00007fd3547b5000)
    libgcrypt.so.20 => /lib/x86_64-linux-gnu/libgcrypt.so.20 (0x00007fd35449a000)
    libnsl.so.1 => /lib/x86_64-linux-gnu/libnsl.so.1 (0x00007fd354280000)
    libFLAC.so.8 => /usr/lib/x86_64-linux-gnu/libFLAC.so.8 (0x00007fd354009000)
    libogg.so.0 => /usr/lib/x86_64-linux-gnu/libogg.so.0 (0x00007fd353e00000)
    libvorbis.so.0 => /usr/lib/x86_64-linux-gnu/libvorbis.so.0 (0x00007fd353bd5000)
    libvorbisenc.so.2 => /usr/lib/x86_64-linux-gnu/libvorbisenc.so.2 (0x00007fd35392c000)
    libgpg-error.so.0 => /lib/x86_64-linux-gnu/libgpg-error.so.0 (0x00007fd353717000)



RE: Instalacija programa iz .tar.bz2 fajla - promis - 11.11.2018. 23.44

S obzirom da postoji verzija programa koja je kompajliarana i spakovana kao DEB paket, mislim da je izlišno da pokrećeš binarnu datoteku koja je preuzeta ko zna odakle.
Instaliraj Ubuntu paket programa kao što je naveo calexx.


RE: Instalacija programa iz .tar.bz2 fajla - Kolega2357 - 12.11.2018. 23.11

Kako to da uradim?


RE: Instalacija programa iz .tar.bz2 fajla - zika - 13.11.2018. 08.11

Pazite, .deb file-ovi koje pominjete u repository-ju(mu) koji nudite su iz 2010. godine ili ja nešto, ozbiljnije, grešim?
Premešteno sa pijace na mesto za ovakve razgovore...


RE: Instalacija programa iz .tar.bz2 fajla - promis - 13.11.2018. 09.59

Poslednja verzija tog programa jeste iz 2010.
Čitajući tekst sa download strane, ima tu dosta toga da se ispoštuje da bi ovo što je trenutno preuzeto radilo. A pitanje je da li je dovoljno samo da se instaliraju ti debovi.