Ubuntu-RS forumi
starija verzija jave - Verzija za Štampu

+- Ubuntu-RS forumi (http://forum.ubuntu-rs.org)
+-- Forum: Ubuntu opšta podrška (/Forum-ubuntu-opsta-podrska)
+--- Forum: Opšte diskusije (/Forum-opste-diskusije)
+--- Tema: starija verzija jave (/Thread-starija-verzija-jave)



starija verzija jave - draganbc - 07.04.2020. 16.54

Pozdrav !

Potrebna mi je pomoć , moram da instaliram verziju jave JRE 8 update 152 . Na koji način da to odradim ? Program koji mi je potreban na poslu radi samo sa ovom verzijom jave ( ili starijom ) .


RE: starija verzija jave - promis - 07.04.2020. 19.25

Stare verzije
https://www.oracle.com/java/technologies/javase/javase8-archive-downloads.html
Uputstvo za instaliranje, bilo koje verzije, imaš na forumu već dato.


RE: starija verzija jave - zika - 08.04.2020. 06.00

Rekao bih, u najkraćem, da bi Vam pomoglo:
Kod:
sudo apt install openjdk-8-jre-headless
To je, kod mene (20.04): version 8u252-b07-1 pa me nemojte držati za reč jer je vrlo ograničen skup podataka koji ste nam dâli (čak ni izdanje Ubuntu a postavili ste pitanje ovde gde se daju važni odgovori za AP tako da ni time niste dali neku naznaku)...


RE: starija verzija jave - Cvetan - 08.04.2020. 08.09

(07.04.2020. 16.54 )draganbc Piše:  Pozdrav !

Potrebna mi je pomoć , moram da instaliram verziju jave JRE 8 update 152 . Na koji način da to odradim ? Program koji mi je potreban na poslu radi samo sa ovom verzijom jave ( ili starijom ) .
Malo mi je verovatno da ne radi sa minor verzijom novijom od 152. Pretpostavljam da će svaki JRE iz verzije 8 raditi.

Predlažem Zulu JRE odavde: https://www.azul.com/downloads/zulu-community/?version=java-8-lts&os=ubuntu&architecture=x86-64-bit&package=jre

I već opisano uputstvo. Sa izuzetkom da vam (verovatno ne treba) javac već samo java.


RE: starija verzija jave - Marko.munze - 22.04.2020. 18.14

(08.04.2020. 06.00 )zika Piše:  Rekao bih, u najkraćem, da bi Vam pomoglo:
Kod:
sudo apt install openjdk-8-jre-headless
To je, kod mene (20.04): version 8u252-b07-1 pa me nemojte držati za reč jer je vrlo ograničen skup podataka koji ste nam dâli (čak ni izdanje Ubuntu a postavili ste pitanje ovde gde se daju važni odgovori za AP tako da ni time niste dali neku naznaku)...
Tako je. Ovime bi trebalo da vam je rešen problem. Inače, pošto sam radim na javi malo mi je čudno da je nešto toliko specifično da traži samo ovu verziju jre-a. U principu java je generalno kompatibilna sa svime što je starija verzija. Drugim rečima, ako je neki program pisan u javi 7 praktično su šanse ravne nuli da neće raditi na nekim novijim verzijama jre-a, osim ako nije problem u nečem drugom.
Ispravio sam činjenicu da je pisac ove poruke svoje pisanje postavio tako da je izgledalo kao da je to deo mog odgovora koji je naveo.